Cyberpunk 2077: PC System Requirements to Run Phantom Liberty DLC

by Gamingstry

When it was released, Cyberpunk 2077‘s PC version failed to impress, due to significant optimization issues that were gradually addressed with successive updates. Even though the game is three years old now, you still need a decent hardware system to enjoy the title in the best possible conditions, and this applies even more to its Phantom Liberty expansion. A few days before the launch of Phantom Liberty, CD Projekt Red revealed its initial PC system requirements.

As you’d expect, the game won’t run smoothly on low-end systems. If you want to play the DLC at maximum performance, including ray-tracing, you’ll need a configuration including a GeForce RTX 4080 and an i9-12900 or Ryzen 9 7900X processor.

Fortunately, configurations without ray-tracing are a little more affordable, as you can see for yourself in a comparison table published by CD Projekt Red. If you’d like to see whether your machine is capable of running the Phantom Liberty expansion, you can use this table, keeping in mind that the game will require an SSD to run.

As a reminder, Phantom Liberty will be available in Cyberpunk 2077 starting September 26.

Related Posts

Leave a Comment

This website uses cookies to improve your experience. We'll assume you're ok with this, but you can opt-out if you wish. Accept Read More